$re = '/(Hello there|\G(?!\A)) *\K\S/m';
$str = 'Hello there Cory Klein
Have fun
Hello there Samantha Rodgers';
$subst = "x";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;