const regex = /(Hello there|\G(?!\A)) *\K\S/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Hello there|\\G(?!\\A)) *\\K\\S', 'gm')
const str = `Hello there Cory Klein
Have fun
Hello there Samantha Rodgers`;
const subst = `x`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);