# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(([a-zá-ú]+)[\.,]?\s[A-ZÃ-Úa-zá-ú]){3,}\1/$1$1/gm;t' <<< "¡No, no, no, no, no, no, no, no, no!
No no no no no no.
No. No. No. No. No. No."