re = /(([a-zá-ú]+)[\.,]?\s[A-ZÃ-Úa-zá-ú]){3,}\1/m
str = '¡No, no, no, no, no, no, no, no, no!
No no no no no no.
No. No. No. No. No. No.'
subst = '$1$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result