import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([a-zá-ú]+)[\\.,]?\\s[A-ZÃ-Úa-zá-ú]){3,}\\1";
final String string = "¡No, no, no, no, no, no, no, no, no!\n\n"
+ "No no no no no no.\n\n"
+ "No. No. No. No. No. No.";
final String subst = "$1$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}