#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(([a-zá-ú]+)[\.,]?\s[A-ZÃ-Úa-zá-ú]){3,}\1"
Local $sString = "¡No, no, no, no, no, no, no, no, no!" & @CRLF & _
"" & @CRLF & _
"No no no no no no." & @CRLF & _
"" & @CRLF & _
"No. No. No. No. No. No."
Local $sSubst = "$1$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)