using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([a-zá-ú]+)[\.,]?\s[A-ZÃ-Úa-zá-ú]){3,}\1";
string substitution = @"$1$1";
string input = @"¡No, no, no, no, no, no, no, no, no!
No no no no no no.
No. No. No. No. No. No.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}