use strict;
my $str = '¡No, no, no, no, no, no, no, no, no!
No no no no no no.
No. No. No. No. No. No.';
my $regex = qr/(([a-zá-ú]+)[\.,]?\s[A-ZÃ-Úa-zá-ú]){3,}\1/mp;
my $subst = '$1$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";