const regex = /(([a-zá-ú]+)[\.,]?\s[A-ZÃ-Úa-zá-ú]){3,}\1/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([a-zá-ú]+)[\\.,]?\\s[A-ZÃ-Úa-zá-ú]){3,}\\1', 'gm')
const str = `¡No, no, no, no, no, no, no, no, no!
No no no no no no.
No. No. No. No. No. No.`;
const subst = `$1$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);