using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?(DEFINE)
(?<string>'[^']+')
(?<array> \[ (?: (?&arrayitem) (?> , \s* (?&arrayitem) )* )? \] )
(?<arrayitem> \s* (?&string) \s* => \s* (?&value) \s* )
(?<value> (?&string) | (?&array) )
)
(?&value)";
string input = @"@include ('file_to_load','param1,something',['elem'=>'also, a comma','other'=>['nested' => 'array']])";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}