use strict;
my $str = '@include (\'file_to_load\',\'param1,something\',[\'elem\'=>\'also, a comma\',\'other\'=>[\'nested\' => \'array\']])';
my $regex = qr/(?(DEFINE)
(?<string>'[^']+')
(?<array> \[ (?: (?&arrayitem) (?> , \s* (?&arrayitem) )* )? \] )
(?<arrayitem> \s* (?&string) \s* => \s* (?&value) \s* )
(?<value> (?&string) | (?&array) )
)
(?&value)/xp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}