re = /(?(DEFINE)
(?<string>'[^']+')
(?<array> \[ (?: (?&arrayitem) (?> , \s* (?&arrayitem) )* )? \] )
(?<arrayitem> \s* (?&string) \s* => \s* (?&value) \s* )
(?<value> (?&string) | (?&array) )
)
(?&value)/x
str = '@include (\'file_to_load\',\'param1,something\',[\'elem\'=>\'also, a comma\',\'other\'=>[\'nested\' => \'array\']])'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end