import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ " (?<string>'[^']+')\n"
+ " (?<array> \\[ (?: (?&arrayitem) (?> , \\s* (?&arrayitem) )* )? \\] )\n"
+ " (?<arrayitem> \\s* (?&string) \\s* => \\s* (?&value) \\s* )\n"
+ " (?<value> (?&string) | (?&array) )\n"
+ ")\n"
+ "(?&value)";
final String string = "@include ('file_to_load','param1,something',['elem'=>'also, a comma','other'=>['nested' => 'array']])";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}