$re = '/(?(DEFINE)
(?<string>\'[^\']+\')
(?<array> \[ (?: (?&arrayitem) (?> , \s* (?&arrayitem) )* )? \] )
(?<arrayitem> \s* (?&string) \s* => \s* (?&value) \s* )
(?<value> (?&string) | (?&array) )
)
(?&value)/x';
$str = '@include (\'file_to_load\',\'param1,something\',[\'elem\'=>\'also, a comma\',\'other\'=>[\'nested\' => \'array\']])';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);