const regex = /(?(DEFINE)
(?<string>'[^']+')
(?<array> \[ (?: (?&arrayitem) (?> , \s* (?&arrayitem) )* )? \] )
(?<arrayitem> \s* (?&string) \s* => \s* (?&value) \s* )
(?<value> (?&string) | (?&array) )
)
(?&value)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE)
(?<string>\'[^\']+\')
(?<array> \\[ (?: (?&arrayitem) (?> , \\s* (?&arrayitem) )* )? \\] )
(?<arrayitem> \\s* (?&string) \\s* => \\s* (?&value) \\s* )
(?<value> (?&string) | (?&array) )
)
(?&value)', 'g')
const str = `@include ('file_to_load','param1,something',['elem'=>'also, a comma','other'=>['nested' => 'array']])`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}