# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^\*[^*]*\*?$|^[^*]*\*$)//gm;t' <<< "foo BAR, FOO1*
*FOO, bar% foo
*foo). BAR\", fOo*
**foo BAR foo
*foo bar foo**
foo bar * foo
foo bar foo"