import Foundation
let pattern = #"(^\*[^*]*\*?$|^[^*]*\*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
foo BAR, FOO1*
*FOO, bar% foo
*foo). BAR", fOo*
**foo BAR foo
*foo bar foo**
foo bar * foo
foo bar foo
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)