$re = '~(^\*[^*]*\*?$|^[^*]*\*$)~m';
$str = 'foo BAR, FOO1*
*FOO, bar% foo
*foo). BAR", fOo*
**foo BAR foo
*foo bar foo**
foo bar * foo
foo bar foo';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;