#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^\*[^*]*\*?$|^[^*]*\*$)"
Local $sString = "foo BAR, FOO1*" & @CRLF & _
"" & @CRLF & _
"*FOO, bar% foo" & @CRLF & _
"" & @CRLF & _
"*foo). BAR", fOo*" & @CRLF & _
"" & @CRLF & _
"**foo BAR foo" & @CRLF & _
"" & @CRLF & _
"*foo bar foo**" & @CRLF & _
"" & @CRLF & _
"foo bar * foo" & @CRLF & _
"" & @CRLF & _
"foo bar foo"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)