use strict;
my $str = 'foo BAR, FOO1*
*FOO, bar% foo
*foo). BAR", fOo*
**foo BAR foo
*foo bar foo**
foo bar * foo
foo bar foo';
my $regex = qr~(^\*[^*]*\*?$|^[^*]*\*$)~mp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";