using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\*[^*]*\*?$|^[^*]*\*$)";
string substitution = @"";
string input = @"foo BAR, FOO1*
*FOO, bar% foo
*foo). BAR"", fOo*
**foo BAR foo
*foo bar foo**
foo bar * foo
foo bar foo";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}