package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^\*[^*]*\*?$|^[^*]*\*$)`)
var str = `foo BAR, FOO1*
*FOO, bar% foo
*foo). BAR", fOo*
**foo BAR foo
*foo bar foo**
foo bar * foo
foo bar foo`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}