import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\\*[^*]*\\*?$|^[^*]*\\*$)";
final String string = "foo BAR, FOO1*\n\n"
+ "*FOO, bar% foo\n\n"
+ "*foo). BAR\", fOo*\n\n"
+ "**foo BAR foo\n\n"
+ "*foo bar foo**\n\n"
+ "foo bar * foo\n\n"
+ "foo bar foo";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}