# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(text)(?!<\\/a>)/<a href='somelink.php'>$1<\/a>/gm;t' <<< "this is sample text about something what is text.
this is sample <a href='somelink.php'>text</a> about something what is <a href='somelink.php'>text</a>."