using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(text)(?!<\/a>)";
string substitution = @"<a href='somelink.php'>$1</a>";
string input = @"this is sample text about something what is text.
this is sample <a href='somelink.php'>text</a> about something what is <a href='somelink.php'>text</a>.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}