#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(text)(?!<\/a>)"
Local $sString = "this is sample text about something what is text." & @CRLF & _
"" & @CRLF & _
"this is sample <a href='somelink.php'>text</a> about something what is <a href='somelink.php'>text</a>."
Local $sSubst = "<a href='somelink.php'>$1</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)