import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(text)(?!<\\/a>)";
final String string = "this is sample text about something what is text.\n\n"
+ "this is sample <a href='somelink.php'>text</a> about something what is <a href='somelink.php'>text</a>.";
final String subst = "<a href='somelink.php'>$1</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}