const regex = /(text)(?!<\/a>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(text)(?!<\\\/a>)', 'gm')
const str = `this is sample text about something what is text.
this is sample <a href='somelink.php'>text</a> about something what is <a href='somelink.php'>text</a>.`;
const subst = `<a href='somelink.php'>$1</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);