# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(text)(?!<\/a>)"
test_str = ("this is sample text about something what is text.\n\n"
"this is sample <a href='somelink.php'>text</a> about something what is <a href='somelink.php'>text</a>.")
subst = "<a href='somelink.php'>$1</a>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.