use strict;
my $str = 'this is sample text about something what is text.
this is sample <a href=\'somelink.php\'>text</a> about something what is <a href=\'somelink.php\'>text</a>.';
my $regex = qr/(text)(?!<\/a>)/mp;
my $subst = '<a href=\'somelink.php\'>$1</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";