# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!:\/\/)www\./http:\/\/www./g;t' <<< "http://www.dddd.com
www.new.com"