use strict;
my $str = 'http://www.dddd.com
www.new.com';
my $regex = qr~(?<!://)www\.~p;
my $subst = 'http://www.';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";