const regex = new RegExp('(?<!://)www\\.', 'g')
const str = `http://www.dddd.com
www.new.com`;
const subst = `http://www.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);