import Foundation
let pattern = #"(?<!://)www\."#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
http://www.dddd.com
www.new.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"http://www."#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)