$re = '~(?<!://)www\.~';
$str = 'http://www.dddd.com
www.new.com';
$subst = "http://www.";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;