#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d+(-)\d+\s+\w+"
Local $sString = "CAR,10-20 miles,SALES" & @CRLF & _
"0-10 miles,TRAIN,,TEACHER" & @CRLF & _
"CAR,SALES,10-20 miles" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Pattern 1: ^([^,])+" & @CRLF & _
"Pattern 2:\d+(-)\d+" & @CRLF & _
"Pattern 3: [^,]*$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")