re = /\d+(-)\d+\s+\w+/m
str = 'CAR,10-20 miles,SALES
0-10 miles,TRAIN,,TEACHER
CAR,SALES,10-20 miles
Pattern 1: ^([^,])+
Pattern 2:\\d+(-)\\d+
Pattern 3: [^,]*$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end