import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+(-)\\d+\\s+\\w+";
final String string = "CAR,10-20 miles,SALES\n"
+ "0-10 miles,TRAIN,,TEACHER\n"
+ "CAR,SALES,10-20 miles\n\n\n"
+ "Pattern 1: ^([^,])+\n"
+ "Pattern 2:\\d+(-)\\d+\n"
+ "Pattern 3: [^,]*$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}