// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d+(-)\d+\s+\w+").unwrap();
let string = "CAR,10-20 miles,SALES
0-10 miles,TRAIN,,TEACHER
CAR,SALES,10-20 miles
Pattern 1: ^([^,])+
Pattern 2:\\d+(-)\\d+
Pattern 3: [^,]*$";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}