package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+(-)\d+\s+\w+`)
var str = `CAR,10-20 miles,SALES
0-10 miles,TRAIN,,TEACHER
CAR,SALES,10-20 miles
Pattern 1: ^([^,])+
Pattern 2:\d+(-)\d+
Pattern 3: [^,]*$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}