using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+(-)\d+\s+\w+";
string input = @"CAR,10-20 miles,SALES
0-10 miles,TRAIN,,TEACHER
CAR,SALES,10-20 miles
Pattern 1: ^([^,])+
Pattern 2:\d+(-)\d+
Pattern 3: [^,]*$";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}