use strict;
my $str = 'CAR,10-20 miles,SALES
0-10 miles,TRAIN,,TEACHER
CAR,SALES,10-20 miles
Pattern 1: ^([^,])+
Pattern 2:\\d+(-)\\d+
Pattern 3: [^,]*$';
my $regex = qr/\d+(-)\d+\s+\w+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}