$re = '/\d+(-)\d+\s+\w+/m';
$str = 'CAR,10-20 miles,SALES
0-10 miles,TRAIN,,TEACHER
CAR,SALES,10-20 miles
Pattern 1: ^([^,])+
Pattern 2:\\d+(-)\\d+
Pattern 3: [^,]*$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);