# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([{,]\s*)([^"':]+)(\s*:)/\1"\2"\3/g;t' <<< "[{
storeName: \"testName\",
address: \"12345 Road\",
address2: \"Suite 500\",
city: \"testCity\",
storeImage: \"http://www.testLink.com\",
state: \"testState\",
phone: \"999-999-9999\",
lat: 99.9999, lng: -99.9999
}]"