// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"([{,]\s*)([^"':]+)(\s*:)"#).unwrap();
let string = "[{
storeName: \"testName\",
address: \"12345 Road\",
address2: \"Suite 500\",
city: \"testCity\",
storeImage: \"http://www.testLink.com\",
state: \"testState\",
phone: \"999-999-9999\",
lat: 99.9999, lng: -99.9999
}]";
let substitution = "\\1\"\\2\"\\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}