const regex = /([{,]\s*)([^"':]+)(\s*:)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([{,]\\s*)([^"\':]+)(\\s*:)', 'g')
const str = `[{
storeName: "testName",
address: "12345 Road",
address2: "Suite 500",
city: "testCity",
storeImage: "http://www.testLink.com",
state: "testState",
phone: "999-999-9999",
lat: 99.9999, lng: -99.9999
}]`;
const subst = `\1"\2"\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);