import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\{,]\\s*)([^\"':]+)(\\s*:)";
final String string = "[{\n"
+ " storeName: \"testName\", \n"
+ " address: \"12345 Road\", \n"
+ " address2: \"Suite 500\", \n"
+ " city: \"testCity\", \n"
+ " storeImage: \"http://www.testLink.com\", \n"
+ " state: \"testState\", \n"
+ " phone: \"999-999-9999\", \n"
+ " lat: 99.9999, lng: -99.9999\n"
+ "}]";
final String subst = "\\1\"\\2\"\\3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}