using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:http:\/\/)?www.liveleak.com\/view\?i=(\w{14})";
string input = @"www.liveleak.com/view?i=3f5_1213987712
http://www.liveleak.com/view?i=3f5_1213987712";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}