import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:http:\\/\\/)?www.liveleak.com\\/view\\?i=(\\w{14})";
final String string = "www.liveleak.com/view?i=3f5_1213987712\n"
+ "http://www.liveleak.com/view?i=3f5_1213987712";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}