re = /(?:http:\/\/)?www.liveleak.com\/view\?i=(\w{14})/i
str = 'www.liveleak.com/view?i=3f5_1213987712
http://www.liveleak.com/view?i=3f5_1213987712'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end